Back to overview
Resolved

Power Systems Maintenance

Jul 4, 2026 at 6:45am UTC  –  Jul 4, 2026 at 10:04am UTC
Affected services
Matrix 3
Matrix Content Delivery
NaviGo Web Application

Resolved
Jul 4, 2026 at 10:04am UTC

Maintenance ended

Updated
Jul 4, 2026 at 10:04am UTC

Maintenance is complete and all services are back online

Created
Jul 4, 2026 at 6:45am UTC

Our services will be unavailable during the listed time period whilst external contractors perform maintenance on our data centre power supply.